Jump to content
ktsaved

Up2date.exe causes memory paging and server "hang"

Recommended Posts

Yes, my server running the Admin Kit is a Domain Controller as well.

 

Josh

 

My installation is also on SBS 2003, containing a domain controller.

 

I also run Symantec Backup Exec. Is anyone else using this?

 

I had some remnants of Symantec security software in my system, which I manually removed. Removing thes made no difference.

 

One Kaspersky tech identified the Symantec Volume Snapshot component as being incompatible, along with other Symantec software. I replied explaining that these components were part of Backup Exec and not part of any security software. I asked if Kaspersky was incompatible with Backup Exec. I have not received a reply to this question, even though I emailed it twice back to the support tech assigned to my case. Since then I have heard nothing back from Kaspersky. I am wondering if he was fishing for solutions because the processes were from Symantec vs these processes really being incompatible.

 

I ran fine with Backup Exec and Kaspersky for over a year before the problem started surfacing. It began being very intermittent, and finally came to the point that it will happen with every update that overwrites previously downloaded definition updates.

 

KTSaved

Share this post


Link to post
Please give the case number

 

Also, my case number is CAS-603138-MVNBDM.

 

Like I said, I have not received any replies to my last two emails.

 

Thanks,

KTSaved.

Share this post


Link to post

I do use BE 2010 R2, however no Symantec components are installed on the server that KAK is on.

 

J

Share this post


Link to post
I also run Symantec Backup Exec. Is anyone else using this?

 

Yes.

I'm running Symantec Backup Exec for Windows Servers 11d with SP3 (v11.0 Rev. 6235) on the machine.

(Includes the Agent for MS Exchange & Remote Agent for Windows Servers.)

 

No other Symantec software has been installed on the machine.

 

Unfortunately, I don't know exactly when this Up2date memory paging issue started happening on this machine.

 

Thanks for the collaboration; eventually we'll get this mystery solved - that's what we do. :)

 

Josh

 

Share this post


Link to post

I wonder if some of you could try to run an update from within the AV Client on your server?

 

I am curious if this issue also will happen with you via this method also. This method does not use up2date.exe. The issue seems to happen when the update process gets to a certain file then continues until the update is ended or the process is stopped.

 

This may help Kaspersky to identify the problem.

 

Thanks,

KTSaved

Share this post


Link to post

Just ran an update from my workstation manually ... it seemed to make no appreciable difference on the KAK server. (I watched task manager via RDP).

 

HTH

J

Share this post


Link to post

I have no Symantec. I use Acronis bakcup& Recovery.

 

It is crazy by me. Since October i have a new Server hardware and the problems began. With my old Server with the same Software on it no problems. Very crazy.

Share this post


Link to post

Ok, so another possible thing .... did everyone who is having the problem do a clean install of KAK 8.0.2134?

 

Or do we have upgrades that do it as well?

 

(I'm wondering if something left over from a previous version of KAK prevents the issue from happening?)

 

J

Share this post


Link to post
Ok, so another possible thing .... did everyone who is having the problem do a clean install of KAK 8.0.2134?

 

Or do we have upgrades that do it as well?

 

(I'm wondering if something left over from a previous version of KAK prevents the issue from happening?)

 

J

 

My installation is an upgrade.

 

Thanks.

Share this post


Link to post
I have no Symantec. I use Acronis bakcup& Recovery.

 

It is crazy by me. Since October i have a new Server hardware and the problems began. With my old Server with the same Software on it no problems. Very crazy.

 

Around the end of September/ October is also when my problems began.

But, no hardware changes for me.

 

Thanks.

Share this post


Link to post

I had make a clean install without backup anything.

 

If i boot my old hardware, i still don´t have this problems.

 

Nice to hear that your problems began on the same time. September/October

 

I had uninstall all Kaspersky software and install the older Version from the AdminKit. The same problem. Using only AdminKit on the server wihout any Exchange or Fileserver Security, the same problem.

 

But since i use the Universal Updater, and let download the Updates in the same folder as the AK i don´t have any crash or freeze on my server. And no error logmessages

 

it is very strange.

Edited by Dandy-power

Share this post


Link to post

In germany some customers are getting an inoffical fix but it seems that this doesn´t solve this issue.

Share this post


Link to post

On my machine with MS SQL Server 2005 installed, I notice the MSSQLSERVER service is logging an event ID 17890 every time the update task runs and flushes the RAM.

Event ID 17890 is: "A significant part of sql server process memory has been paged out. This may result in a performance degradation."

 

It looks like this has been going on since July of 2010. Yikes!!

 

Can't believe it took me this long to notice the problem, although in my defense, the update task only executed at off-peak times. :)

 

I ran Filemon & Regmon while Up2Date was running, but couldn't see anything interesting at the failure time. Bummer.

 

I also toggled the /3GB switch off & on, but that didn't help.

 

Do we know if Kaspersky is able to reproduce this problem in the lab?

 

I suspect it is affecting many more people who aren't even aware the issue is happening, as nothing actually 'crashes' (at least in my case).

 

Thanks,

Josh

 

Share this post


Link to post

Yes, it was mentioned several posts ago by several people.

 

Following that KB article doesn't resolve the issue.

 

J

Share this post


Link to post

installing Cumulative Update 6 for SQL Server 2005 has alleviated most of our event 17890 problems. it seems when running sql server on Windows 2003 x64, page locking is not honored.

Share this post


Link to post

I tried 2005 SP4 (having been on SP3 CU9 for a while), that didn't help.

 

Now running on SQL 2008 R2 Express edition and still getting the errors - so I'm pretty sure it isn't a SQL issue.

 

Besides, the errors always happen when up2date is running and the timing of the errors followed the time change of my Task schedule in KAK I made as an experiment.

 

J

Share this post


Link to post

greeting all

 

I have same problem as you al and in my case the server hang for about 1,5 hours

when there is no history of the update ( a clear update repository) the update give no problem when the repository is not empty the server gets problem.

 

I have made a temporal solution so that I can have latest update without getting the problems whit the server.

 

I have set the update at 1 one time a day, just before I start the update I delete the update repository through a schedule task. (this way It will go automatic)

this mean you update/dowload every file anew from the update server from kaspersky!

 

edit are spelling (I have a bad English writing)

Edited by systemc

Share this post


Link to post
Please give the Universal Updater a change instead of the global update task.

 

It works by a lot of my customers.

 

That isn't really a solution for those of us running KAK on a domain controller or in a SBS environment.

 

Leaving a DC logged-in and "locked" isn't exactly the most secure (or best practice) option.

 

We need a proper fix, not some kind of unsupported kludge (even if it is a reliable kludge).

 

(Although, the updater didn't update my clients for me, so I was less then impressed personally).

 

J

Share this post


Link to post

This tool is a workaround for the time who KL needs to fix the problem.

 

The client update are doing with the AdminKit.

 

You can also create a task inside the admin kit to run this tool. Read this FAQ point 4.

Edited by Helmut

Share this post


Link to post

I have exactly same problem on 3 servers :

 

2 servers with 2003 server x64

1 server with 2003 x86.

 

I'm not sure but it seems happening with Admin Kit ONLY installed (no fileserver protection) OR with file server protection and no admin kit.

 

this afternoon, on a server with no protection, after installing Antivirus 8 for Enterprise File Server + MMC snap in, the server freeze after few minutes.....

 

 

Share this post


Link to post

Hi there,

 

it took me days to determine the sporadic server lockups at my clients. :-(

 

I can describe the Problem with the Kaspersky Updater as following:

 

1. Most of the servers do not respond either on the console when the up2date task runs, but not at every update. I think the problems could have to do with the unavailibility of the update server ressources at kaspersky lab. Today at around 12pm the administration server could not connect to multiple update servers at kaspersky labs. in the following time the memory of all !! programs got flushed and the server (terminalserver !) was not usable. Just when I stopped the sql server service and disabled the hourly automatic update, the server came back.

 

I do not know what is happening there, but hopefully there will be a fix in the near future.

 

Are there any new information?

 

Best regards from germany

Eike

Edited by Medas Computers

Share this post


Link to post

×
×
  • Create New...

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.