Jump to content
ktsaved

Up2date.exe causes memory paging and server "hang"

Recommended Posts

Hi.

 

When the updater (Upd2date.exe) in the Admin Kit Ver 8.0.2134 (also the previous version) runs, sometime during the download process it is causing excessive memory paging in which the server "hangs" (extremely slow in responding to anything: windows changes, network communication causing network app problems, etc.), and all processes running in memory are reduced to very low values. For example, I may have Store.exe running at 150 MB, and SQL instance running at 250 MB, some Kasperksy services running at over 100 MB, and so on for all the running processes. When this happens, for example, I have watched SQL be reduced to under 1 MB and the same for other processes. When it is all finished, these processes quickly begin to take up memory and return to more normal levels. The server will run ok until the next time Up2date.exe runs, then the same thing happens.

 

Up2date.exe itself is not using much RAM, maybe around 15-30 MB or something like that, I can't remember the exact value. No other process is suddenly taking alot of RAM. The isssue happens when Up2date.exe runs, and the server runs with somewhere between 1 and 1.5 Gig of free memory when this happens.

 

It took some time to narrow down the problem. I now am running the server with the update schedule in the Admin Kit disabled, and the server is running fine. No memory or paging issues. The processes have returned to normal levels and are maintaining them fine.

 

With the scheduler off, SQL can reach around 450 MB, Store.exe can reach 650 MB, which are more normal levels. When the updater is enabled, they never reach these levels because the issue causes them all to be page out or reduced in size.

 

Also when this happens, free memory will jump from maybe 1.4 GB free to almost 3 GB free on a 4 GB system. Free memory then goes down quickly as the processes start taking up more RAM to run.

 

If I manually run the update from the Admin Kit, the issue happens.

 

I look for your advice in solving this issue.

 

Windows SBS 2003 SP2

4 GB RAM

Two Zeon quad cores 2.33 Ghz

Kaspersky Total Space Security

 

Thanks,

KTsaved

Share this post


Link to post

Having exact same problem. I installed a trial version for a client last week, since then the server has come up with low virtual memory. up2date.exe shownig high cpu/mem usage.

 

Since then the server has rebooted itself twice so far.. It's affecting other 3rd party programs such as Exchange and ShadowProtect..

Share this post


Link to post

I have a little additonal info to add.

 

I deleted the files in the Updates folder. I then ran a manual update, and everything ran ok with not issues.

 

So, I ran another manual update without deleting any files. This time as it got to a certain file, the issue happened. Memory used by processes was instantly reduced to very low levels, with the server "hanging". This continued until that file was finished, then everything was ok. The processes started to gain more memory back, the server stopped "hanging". That file may have also been the last file in the update. The issue didn't last as long this time, maybe because it was the last file or maybe it hangs on certain files?

 

Thanks,

KTsaved.

Share this post


Link to post
KB 4210 or try this 4340 and run the update task again.

 

That has not fixed the issue for me.

 

Still seeing up2date.exe freezing the server for a 5 minute window every time the admin kit update task runs.

 

KAK 8.0.2134

KAV 6 MP4 (autopatch d)

Windows 2003 R2 SP2 (x86)

2 GB RAM

Dual Core Xenon CPU

 

When will there be a proper fix for this available? (the issue looks at though it is already several months old - much older than December looking at google)

 

Thanks

J

Share this post


Link to post

This workaround helps by some of my customers.

 

Download the Universal Updater and install it on the same computer as the administration kit.

 

Set the destination for the updates to the share of the AK and shedule the download as you want.

 

Set the normal update task to manual.

Share this post


Link to post

Thanks, I'll give that a try - although I'm concerned by the "this version is not supported" message on that download page.

 

Do you know if Kaspersky are planning to address this issue in the next release of KAK?

 

J

Share this post


Link to post

You are right the Updater is not supported bur this tool runs very stable. I use this tool over a long time in my test environment.

 

The problem with up2date.exe is not a generell problem. Did you create a trace and send this file to the support?

Share this post


Link to post

Not yet, as it looked like I wasn't alone with this issue.

 

Can you point me towards instructions on how to create the trace please? I will then open a support incident.

 

Thanks

J

Share this post


Link to post
You can find the instruction here.

 

I have not posted back in this message board because I have opened a support case and have worked with tech support to no avail. In fact, they have not responded to my last communication with them. The suggestions they offered did not help, and one tech even said he saw no problem with my screenshot of all processes being emptied of memory in use.

 

I want to add that this problem also occurs for me when I try to do an update with the AV client on the server. This method does not use up2date.exe. It acts the same, however. The update begins to run ok, then when it reaches a certain file, the running processes are emptied of memory, the paging drive runs at 100%, and the server "hangs" until either the update finishes, or I can manage to get the update stopped. I do that by having the process highlighted in Task Manager and ready for me to click to end the process. It sill takes some time to get this to work because of the issue. As soon as the process is stopped, the server starts responding as normal, the processes begin to take up more Ram and the server will run ok.

 

So, for me it happens when the definitions are overwritten by an update, whether up2date.exe is used or the AV client is used.

 

I wanted to post to update my findings in what causes the issue and in case someone else at Kaspersky will see this that knows how to solve.

 

Thanks,

KT

Share this post


Link to post
You are right the Updater is not supported bur this tool runs very stable. I use this tool over a long time in my test environment.

 

I tried it last night. I'm not happy about leaving the server "logged in" to run the application. Can it run as a service?

 

Also, none of my clients are picking the updates up unless I manually start the update process. What options need to be enabled for the clients to get updates if they are set to "when updates are downloaded to the repository"?

 

Thanks

J

Share this post


Link to post

You can block the server with a screen saver then you must type in the password. There are some tool available to create a service for this executable. please use google.

 

You must change the shedule time in the task to the time you want.

Share this post


Link to post
You can block the server with a screen saver then you must type in the password. There are some tool available to create a service for this executable. please use google.

 

You must change the shedule time in the task to the time you want.

 

Thanks for the info, but it looks like I will have to go down the support route for a proper fix.

 

J

Share this post


Link to post

Hello

 

I see i´m not alone with this problem.

 

I have exactly the same problem since October 2010 (Since this time Kaspersky have found no any solution). When the AdminKit makes a update, the Server freeze complete. In the Taskmanager you can see that after the Update all processes had loose their memory.

The funny thing is, when i delete the complete Bases and download again, i have no freeze. I can make the Update 5-6 times without any freeze. But after that the freezes are back.

 

I run the universal Updater since 5 days and no any freeze or crash. It worked very good.

 

Hope that this will be fix fast. Last time i see many others have this problem too.

 

regards Dandy

 

 

Share this post


Link to post

I stay in contact with Kaspersky since October. I have send more than 20 traces :-)

 

In the afternoon i must make a complete dump file from the Memory.

 

I will upload it over Kaspersky FTP

Share this post


Link to post

Hi everyone,

 

First, i'd like to thank mr. ktsaved for the very well explained issue. I'm having the exact same problem. I installed Kaspersky few weeks ago and everything went fine. But now, the server is hanging every hour, during the update of kaspersky. The sintoms are the same. The process up2date.exe itself does not take much memory, but other proccess start to suffocate and the server hangs completely (even ctrl+alt+del takes a long time!).

 

So, although I cannot post a trace right now (the server is in production and the updates are disabled for now), i can ensure that this problem is generic and affecting other people.

 

Tomorrow i'll try to run a trace to help solving this issue.

 

Hope kaspersky engineers are paying attention to us. I chose this software because people always said good about the support and the speed of updates... For now, I'm having no update... And I hope we can get support for this.

 

Thanks,

Daniel Silveira

from Brazil

 

 

Share this post


Link to post

I've logged a support case - UK support couldn't figure the issue from the trace file or event logs and have escilated it to HQ.

 

SRF Details - 165044: Up2date.exe causing issues with slowdowns

 

TIA

J

Share this post


Link to post

 

Hello all.

 

I'm also experiencing this issue of Up2date.exe causing all running processes to flush their memory during an update.

I hope a solution is discovered, soon, as I've had to turn off auto-updating at this point.

 

I tried the 'Clear updates repository' command and redownloaded the updates, but it didn't help the situation.

 

 

Here are the specifics of my setup:

 

Windows Server 2003 R2, Standard Edition, SP2 (x86)

4 GB RAM

Dual Core Xeon CPU

 

Kaspersky Admin Kit version 8.0.2134

 

Workstation Client versions: 6.0.4.1424 with a couple 6.0.3.837.

Network Agent versions: 8.0.2134 with a couple 8.0.2090.

 

Also, Kaspersky Security 5.5 for Microsoft Exchange Server 2003, version 5.5.1388.0 is installed on the same server.

 

Nothing gets logged in the Event Viewer when this happens.

 

Could it be a recent Windows Update causing an issue?

Here are the updates I applied on January 19th:

KB2416400, KB2207559, KB2296199, KB2419635, KB2423089, KB2436673, KB2440591, KB2443105, KB2467659.

 

Thanks for the help,

Josh

 

Share this post


Link to post

No i think it doesn´t happen any Windows Update.

 

I have this Problem with a fresh install Server SBS 2003 too, without any update

Share this post


Link to post

I have an idea about a common condition...

 

If it is an issue on a clean SBS installation ... I wonder if it occurs only when KAK is installed on a domain controller?

 

My KAK is on a secondary DC (it was the only spare server not doing much load-wise).

 

Could this be the cause?

 

Could anyone else having the issue confirm if they have KAK on a domain controller?

 

J

Share this post


Link to post
I have an idea about a common condition...

...

Could anyone else having the issue confirm if they have KAK on a domain controller?

 

J

 

Yes, my server running the Admin Kit is a Domain Controller as well.

 

Josh

 

Share this post


Link to post

×
×
  • Create New...

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.