Jump to content
Marchao

Не работают некоторые компоненты Антивирус Касперского 6.0.4

Recommended Posts

Проблема возникает примерно на 10% устанавливаемых систем ( все системы ХР, сервис пак 2 или 3)

после установки пишет: не работает защита

при попытке запусить компоненты вручную в логе появляются подобные сообщения: Сбой в задаче Файловый Антивирус: неопределенная ошибка

пытался переустанавливать касперского несколько раз в том числе с помощью kavremover10

плз хелп)

Share this post


Link to post

Сегодня обнаружил на 1 ноуте СОНИ (чтоб сони взорвалась со всеми потрохами) такую же хрень.

Для половины задач пишет такую ошибку, для антиспама выводит ещё код 5-значный.

Но юзер комп не вырубает подолгу, закрывая крышку и тем самым отправляя в сон. Попросил перегрузить его комп, щас посмотрю, что будет. При всём этом обновление пашет нормально и базы обновляются.

Большие подозрения, что это чисто бага техники сони в моём случае.

В вашем случае техника какая? Не брендовая случаем?

Share this post


Link to post

Ребут не помог.

В общем грабли неясные. Переустановливать пока не буду, подожду комментов.

Локально В каспере не запущены некоторые задачи, точно не скажу какие, запуск не помогает.

post-27985-1256880318_thumb.png

Share this post


Link to post

У меня такая же проблема на 2-3% процентах компов вторую неделю. Подозреваю кривизну настройки ОС "специалистами", так как половину смог запустить нормально, после того. как удалил и установил заново, но не с помощью агента, а только с учёткой локального root. С 837 билдом и 1710 агентом такого небыло :(.

Share this post


Link to post

Компы собственной сборки (компания занимается сборкой компьютеров) как правило на материнках Асус, пока происходит волновая накатака антивируса и из 38 компов у 3х глюк

Share this post


Link to post
Ребут не помог.

В общем грабли неясные. Переустановливать пока не буду, подожду комментов.

Локально В каспере не запущены некоторые задачи, точно не скажу какие, запуск не помогает.

 

проверте список запущеных драйверов на проблемных машинах.

 

sc query kl1

sc query klfltdev

sc query klif

sc query klim5

 

Share this post


Link to post

Была такая проблема. Полечилась двумя задачами:

1) Деинстал

2) Переинстал

 

:))

Share this post


Link to post
проверте список запущеных драйверов на проблемных машинах.

 

sc query kl1

sc query klfltdev

sc query klif

sc query klim5

RSIT не нашел sc query klif и sc query klim5

Share this post


Link to post

Та же проблема, техподдержка решает уже два недели, вчера ещё дополнительные логи запросили, в понедельник отправлю. Windows XP SP3, MP4 6.0.4.1212 установился без проблем удаленно, но часть компонентов не работает. Удаляли, переставляли локально, чистили реестр. Компьютер работает без проблем, ни сбоев, ни ошибок, вот только MP4 работать не хочет :angry:

Share this post


Link to post

ну как, есть какое-либо решение кроме переустановки системы?

Share this post


Link to post
ну как, есть какое-либо решение кроме переустановки системы?

 

Добрый день!

У меня были похожие сбои с МР4, но я пришёл к выводу, что эти сбои из-за обновлений, так как лечились эти сбои запуском обновления KWS не удалёно с АК, а локально несколько раз (2-3раза) и ошибка пропадала.

При не удачных обновлениях KWS писал, что обновлены не все компоненты и соответственно работали не все компаненты.

Но стоило запустить, сразу же, ещё раз обновление и оно проходило с обновлением всех компонентов и соответственно заработали все компоненты!

Вот так было у меня.

 

Истина где-то рядом.....

Share this post


Link to post
RSIT не нашел sc query klif и sc query klim5

Не совсем понятно, к чему тут упомянут RSIT?

 

ну как, есть какое-либо решение кроме переустановки системы?

Систему переустанавливать не надо, попробуйте переустановить продукт с предварительным удалением его драйверов — sc delete klif

Share this post


Link to post

RSIT выдает информацию о запущенных драйверах

kavremover10 удаляет данный драйвер?

Share this post


Link to post

Должен удалять. А всё-таки, что показывает команда sc query klif ?

Share this post


Link to post

Такая же ошибка. "sc query klfltdev" и "sc query klif" выдают "[sC] EnumQueryServicesStatus:OpenService FAILED 1060:"

 

Share this post


Link to post

Если посмотреть ветку HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\KLIF на проблемной машине, то видно, что она есть, но пустая.

 

Share this post


Link to post

А сам файл klif.sys там есть?

 

Предыдущих версий WKS на проблемных машинах не стояло раньше?

Share this post


Link to post
ну как, есть какое-либо решение кроме переустановки системы?

Похоже, других вариантов нет. В моем случае (Windows XP SP3 со всеми обновлениями, MP4, не работает файловый антивирус и несколько других компонентов) техподдержка уже около месяца проблему решает и так пока ничего полезного не предложила: запустить утилиту подготовки установки, отключить Windows Defender, логи установки по нескольку раз изучали, в итоге заявили, что с логами установки всё в порядке, предложили ещё раз собрать логи и трассировку в момент попытки включения компонентов.

Мое предположение: проблема с правами доступа и по-моему проявляется на тех компьютерах, на которых в процессе работы меняли имя учетной записи или переключали рабочую группу на домен. А как по Вашему проблемному компьютеру: делали что-то подобное после установки Касперского (имею в виду вообще любую версию которая могла стоять до MP4)?

Share this post


Link to post
А сам файл klif.sys там есть?

 

Предыдущих версий WKS на проблемных машинах не стояло раньше?

Файла нет.

Предыдущих версий не было. Был Symantec Endpoint 11.0.4000, успешно автоматически удален в результате установки KAV.

Кусок лога удачной установки (на другой машине):

Exec: Unicode entry point (deferred)

ExecW: CommandLine = "C:\WINDOWS\TEMP\{8F023021-A7EB-45D3-9269-D65264C81729}\drvins32.exe" install klif "C:\WINDOWS\TEMP\{8F023021-A7EB-45D3-9269-D65264C81729}\klif.inf" "C:\WINDOWS\TEMP\{8F023021-A7EB-45D3-9269-D65264C81729}\klif.cat" klif.cat

ExecW: CurrentDir =

ExecW: Wait = yes

ExecW: Username = SYSTEM

MSI (s) (DC:F0) [17:42:26:819]: Executing op: ActionStart(Name=SetKlifParameters,,)

ExecW: process returned (0x00000000)

MSI (s) (DC:F0) [17:42:26:819]: Executing op: CustomActionSchedule(Action=SetKlifParameters,ActionType=3137,Source=BinaryData,

Target=SetKlifParameters,CustomActionData=VersionNT64=|FSSync32=C:\Program Files\Kaspersky Lab\Kaspersky Anti-Virus 6.0 for Windows Workstations MP4\fssync.dll|FSSync64=C:\Program Files\Kaspersky Lab\Kaspersky Anti-Virus 6.0 for Windows Workstations MP4\x64\fssync.dll)

MSI (s) (DC:CC) [17:42:26:829]: Invoking remote custom action. DLL: C:\WINDOWS\Installer\MSI104.tmp, Entrypoint: SetKlifParameters

SetKlifParameters: entry point

SetKlifParameters: SysPatch parameter set to 1

SetKlifParameters: FSSync32 parameter set to C:\Program Files\Kaspersky Lab\Kaspersky Anti-Virus 6.0 for Windows Workstations MP4\fssync.dll

MSI (s) (DC:F0) [17:42:27:680]: Executing op: ActionStart(Name=StartServiceKlifSys,Description=Запуск служб...,)

SetKlifParameters: return point

MSI (s) (DC:F0) [17:42:27:680]: Executing op: CustomActionSchedule(Action=StartServiceKlifSys,ActionType=11329,Source=BinaryDa

ta,Target=**********,CustomActionData=**********)

Кусок неудачной установки:

Exec: Unicode entry point (deferred)

ExecW: CommandLine = "C:\WINDOWS\TEMP\{8F023021-A7EB-45D3-9269-D65264C81729}\drvins32.exe" install klif "C:\WINDOWS\TEMP\{8F023021-A7EB-45D3-9269-D65264C81729}\klif.inf" "C:\WINDOWS\TEMP\{8F023021-A7EB-45D3-9269-D65264C81729}\klif.cat" klif.cat

ExecW: CurrentDir =

ExecW: Wait = yes

ExecW: Username = SYSTEM

MSI (s) (20:7C) [15:20:47:083]: Executing op: ActionStart(Name=SetKlifParameters,,)

ExecW: process returned (0x00000000)

MSI (s) (20:7C) [15:20:47:083]: Executing op: CustomActionSchedule(Action=SetKlifParameters,ActionType=3137,Source=BinaryData,

Target=SetKlifParameters,CustomActionData=VersionNT64=|FSSync32=C:\Program Files\Kaspersky Lab\Kaspersky Anti-Virus 6.0 for Windows Workstations MP4\fssync.dll|FSSync64=C:\Program Files\Kaspersky Lab\Kaspersky Anti-Virus 6.0 for Windows Workstations MP4\x64\fssync.dll)

MSI (s) (20:84) [15:20:47:083]: Invoking remote custom action. DLL: C:\WINDOWS\Installer\MSI12D.tmp, Entrypoint: SetKlifParameters

SetKlifParameters: entry point

SetKlifParameters: SysPatch parameter set to 1

SetKlifParameters: FSSync32 parameter set to C:\Program Files\Kaspersky Lab\Kaspersky Anti-Virus 6.0 for Windows Workstations MP4\fssync.dll

MSI (s) (20:7C) [15:20:47:114]: Executing op: ActionStart(Name=StartServiceKlifSys,Description=Запуск служб...,)

SetKlifParameters: return point

MSI (s) (20:7C) [15:20:47:114]: Executing op: CustomActionSchedule(Action=StartServiceKlifSys,ActionType=11329,Source=BinaryDa

ta,Target=**********,CustomActionData=**********)

MSI (s) (20:68) [15:20:47:130]: Invoking remote custom action. DLL: C:\WINDOWS\Installer\MSI12E.tmp, Entrypoint: StartDriver

MSI (s) (20:7C) [15:20:47:145]: Executing op: ActionStart(Name=ProcessComponents,Description=Обновление регистрации компонентов...,)

StartDriver: OpenService(klif) failed: 0x00000424

MSI (s) (20:7C) [15:20:47:145]: Executing op: ProgressTotal(Total=46,Type=1,ByteEquivalent=24000)

 

SEP 11 был на всех компьютерах. Большинство пока спокойно пережило автоматическое удаление SEP 11 и установку WKS 6.0.4

Edited by _mike_

Share this post


Link to post

Из setupapi.log

#-198 Обработана командная строка: "C:\WINDOWS\TEMP\{8F023021-A7EB-45D3-9269-D65264C81729}\drvins32.exe" install klif "C:\WINDOWS\TEMP\{8F023021-A7EB-45D3-9269-D65264C81729}\klif.inf" "C:\WINDOWS\TEMP\{8F023021-A7EB-45D3-9269-D65264C81729}\klif.cat" klif.cat

#-011 Установка секции [DefaultInstall] из "C:\WINDOWS\TEMP\{8F023021-A7EB-45D3-9269-D65264C81729}\klif.inf".

#E360 Неподписанный или неправильно подписанный файл "c:\windows\temp\{8f023021-a7eb-45d3-9269-d65264c81729}\klif.cat" для драйвера "ActivityMonitor" будет установлен (Политика=Игнорировать). Ошибка 0x800b0110: Данный сертификат не подходит для такого использования.

#-167 SPFILENOTIFY_NEEDMEDIA: Тег="", Описание="Klif Source", ПутьИсточника="C:\WINDOWS\TEMP\{8F023021-A7EB-45D3-9269-D65264C81729}", ФайлИсточника="klif.sys", Флаги=0x00000400.

#E169 SPFILENOTIFY_NEEDMEDIA: возвращено FILEOP_ABORT. Ошибка 1223: Операция была отменена пользователем.

#W187 Ошибка установки, попытка восстановления оригинальных файлов.

Share this post


Link to post

Вручную установил драйвер klif. Перезагрузился - все заработало.

Share this post


Link to post

Похоже у меня была ситуация как здесь. Пользователь призналась, что чего-то нажимала в процессе установки. Хотя вообще не ясно, зачем ей это видеть... Устанавливал средствами автоустановки adminkit 8.

Share this post


Link to post
Вручную установил драйвер klif. Перезагрузился - все заработало.

 

А как вручную его установить? Подскажите пожалуйста.

Share this post


Link to post

Банально в проводнике правой кнопкой по "C:\Program Files\Kaspersky Lab\Kaspersky Anti-Virus 6.0 for Windows Workstations MP4\KLIFX86\klif.inf" -> установить.

Share this post


Link to post
Банально в проводнике правой кнопкой по "C:\Program Files\Kaspersky Lab\Kaspersky Anti-Virus 6.0 for Windows Workstations MP4\KLIFX86\klif.inf" -> установить.

 

Спасибо огромное, заработало

Share this post


Link to post

×
×
  • Create New...

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.