Help - Search - Members
Full Version: KAV is interfering with IE 7's Popup Blocker
Kaspersky Lab Forum > English User Forum > Protection for Home Users > Kaspersky Internet Security & Anti-Virus for Windows
Alpine
I'm having a problem with KAV 7.0.0.125, running on WinXP Pro SP2, and IE 7.

KAV seems to be screwing up IE 7's popup blocker. Ordinarily, if a site tries to open a popup that you want, you can click the icon on IE's status bar and choose to temporarily allow popups from this site during this session. However, since installing KAV 7, if you do that, the popup still doesn't open up, but now there's a KAV icon on IE's status bar in place of the original icon. And when you click on that, the "temporarily allow" option is grayed out, and the only option left is to add this site to the Trusted Sites list. However, even if you click that, the popup still doesn't open, and the site is never added to the list.


Now, if I had Kaspersky's Web AV turned on, I might just chalk this up to a simple bug - but Web AV is disabled, so why is Kaspersky getting in the way in the first place?


How can I truly detach KAV from IE 7, so that I can have this functionality working again?
Clint7
QUOTE(Alpine @ 2.01.2008 15:28) *
I'm having a problem with KAV 7.0.0.125, running on WinXP Pro SP2, and IE 7.

KAV seems to be screwing up IE 7's popup blocker. Ordinarily, if a site tries to open a popup that you want, you can click the icon on IE's status bar and choose to temporarily allow popups from this site during this session. However, since installing KAV 7, if you do that, the popup still doesn't open up, but now there's a KAV icon on IE's status bar in place of the original icon. And when you click on that, the "temporarily allow" option is grayed out, and the only option left is to add this site to the Trusted Sites list. However, even if you click that, the popup still doesn't open, and the site is never added to the list.
Now, if I had Kaspersky's Web AV turned on, I might just chalk this up to a simple bug - but Web AV is disabled, so why is Kaspersky getting in the way in the first place?
How can I truly detach KAV from IE 7, so that I can have this functionality working again?

I am not sure why you would be visiting internet sites without KAV turned on. Have you opened Kaspersky, went to the firewall settings and unchecked popup blocker? I use the I.E. popup blocker and I have kaspersky popup blocker turned off. This works great for me. Hope this helps supercool.gif
Alpine
QUOTE(Clint7 @ 2.01.2008 16:02) *
I am not sure why you would be visiting internet sites without KAV turned on. Have you opened Kaspersky, went to the firewall settings and unchecked popup blocker? I use the I.E. popup blocker and I have kaspersky popup blocker turned off. This works great for me. Hope this helps supercool.gif



I don't have any firewall settings, as far as I can tell. I'm running KAV, not KIS, so I don't even see any place where the popup blocker is mentioned.
Jem
QUOTE(Alpine @ 2.01.2008 21:12) *
I don't have any firewall settings, as far as I can tell. I'm running KAV, not KIS, so I don't even see any place where the popup blocker is mentioned.


I can back this up. I'm also running KAV and I get the same thing very occasionally. You have no firewall or pop-up blocking in KAV - they are KIS features Clint7. This would appear to be a bug that exists even in the MP1 Beta. Can you post a link to a site - a clean one please wink.gif , where this happens, and I'll make sure it's posted appropriately.
Alpine
QUOTE(Jem @ 2.01.2008 16:26) *
I can back this up. I'm also running KAV and I get the same thing very occasionally. You have no firewall or pop-up blocking in KAV - they are KIS features Clint7. This would appear to be a bug that exists even in the MP1 Beta. Can you post a link to a site - a clean one please wink.gif , where this happens, and I'll make sure it's posted appropriately.



http://www.popuptest.com/

The first one on the list, "Multi-PopUp Test", duplicates this behavior - so it makes a good test case, I would imagine. (Others on the page may work to duplicate this bug as well, I just didn't try them after seeing the first one accomplishing this)
Jem
QUOTE(Alpine @ 2.01.2008 22:25) *
http://www.popuptest.com/

The first one on the list, "Multi-PopUp Test", duplicates this behavior - so it makes a good test case, I would imagine. (Others on the page may work to duplicate this bug as well, I just didn't try them after seeing the first one accomplishing this)


Thanks, I've posted this in the bug thread for MP1. We'll see what happens.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.