Help - Search - Members
Full Version: How can I disable virtual keyboard?
Kaspersky Lab Forum > English User Forum > Protection for Home Users > Kaspersky Internet Security & Anti-Virus for Windows
iamntz
I'm evaluating KAV 2014 and, besides the fact the AV keeps telling me that it will expire soon, I have an issue with virtual keyboard, which I don't need nor want. I found how to disable on KIS, but on KAV there is no help entry for this.

The main issue is that is in conflict with some custom shortcut i use (set via autohotkey) on caps lock, scroll lock and so on.

Any idea how i can get rid of the damn keyboard?

Thanks!
rudger79
Welcome. Disable the add-on in your browser.
iamntz
QUOTE(rudger79 @ 5.12.2013 15:14) *
Welcome. Disable the add-on in your browser.


Thanks for reply. But what does browser addon have to do with other apps?

(the addon is not installed anyway)
rudger79
You asked about disabling Virtual Keyboard. With the extension disabled, VK should not be usable.

Not sure what apps you refer to.
iamntz
QUOTE(rudger79 @ 5.12.2013 16:36) *
You asked about disabling Virtual Keyboard. With the extension disabled, VK should not be usable.

Not sure what apps you refer to.

Yet it is. My autohotkey shortcuts does not working correctly (caps lock should be disabled, yet it is not). As soon as i disable KAV, shortcuts magically starts to play nice.

I'm talking about apps like (but not limited to):
Photoshop
Sublimetext (also interferes with ctrl+alt+shift+p shortcut that i used)
Office suite (Outlook, Word, Excel)
Skype

You know... any other app that is not a browser.
rudger79
Let's see if there is something else going on. Please post the link of your GetSystemInfo report by following the four steps outlined here: http://forum.kaspersky.com/index.php?s=&am...post&p=5395
iamntz
Thanks for support, but i'm 100% sure the culprit is KAV virtual keyboard (tested on two PCs, both with windows 8.1). You can test it by yourself by using this snippet for autohotkey:

CODE
^Capslock::Capslock
Capslock::^Insert


Behavior before installing KAV (or when disabling KAV): caps lock doesn't trigger, caps lock indicator is not triggered, defined shortcut is triggered correctly
After installing KAV (or enabling it): caps lock it's trigger sometimes, caps led always is toggled, defined shortcut works sometimes.
Also, pressing ctrl+alt+shift+p (shorcut that i previously used in my editor), the KAV keyboard is showing up.

So, my question is fairly simple: does the KAV keyboard have a Off switch somewhere?

Thanks!
Rodion Nagornov
There is a bug with caps lock button...
VK can't be disabled in KAV settings. You can disable Secure Data Input.
iamntz
Thanks Rodion for your reply. Any hints on how i can do this on KAV? Thanks.
Rodion Nagornov
QUOTE(iamntz @ 6.12.2013 20:55) *
Thanks Rodion for your reply. Any hints on how i can do this on KAV? Thanks.

Settings - Additional - Secure data input - uncheck "Enable secure data input"
voyagerteampl
QUOTE(Rodion Nagornov @ 9.12.2013 10:50) *
Settings - Additional - Secure data input - uncheck "Enable secure data input"


It doesn`t work. I uncheck this box and keyboard still open when I`m using Ctr+Shit+P combination.
It is very annoying.
rudger79
Welcome
QUOTE(voyagerteampl @ 28.12.2013 14:35) *
It doesn`t work. I uncheck this box and keyboard still open when I`m using Ctr+Shit+P combination.
It is very annoying.
Disable it via the browser extension or addon.
voyagerteampl
QUOTE(rudger79 @ 28.12.2013 23:38) *
WelcomeDisable it via the browser extension or addon.

Hi
I removed all Kaspersky addin from browser(Chrome) but problem is in Windows7.
I closed browser, restart win7 and first click Ctrl+Shitf+Alt+P and virtual keyboard are opening.

It still working? Why?
rudger79
Open Kasperksy main window > Settings > Additional > Secure Data Input > uncheck the Option to open Virtual Keyboard by Ctrl+Shitf+Alt+P

Any better?
voyagerteampl
QUOTE(rudger79 @ 29.12.2013 00:11) *
Open Kasperksy main window > Settings > Additional > Secure Data Input > uncheck the Option to open Virtual Keyboard by Ctrl+Shitf+Alt+P

Any better?


Thanks for quick repaly.
I done this. I have empty box there.

You give me solution from user manual - I read this guide wink.gif

Any other sugestions?


Kaspersky Internet Security 14.0.0.4651(d) so i think this version include patches from Your`s tech article.
rudger79
Well, it seems to be a bug, it might be known. I can still open it even disabled in browser and the keyboard shortcut option unchecked, even after reboot.

If you don't want VK to open, I would suggest to not ctrl + shift + alt + P

Of course you could report is to tech support too. http://support.kaspersky.com/helpdesk.html
voyagerteampl
QUOTE(rudger79 @ 29.12.2013 00:25) *
Well, it seems to be a bug, it might be known. I can still open it even disabled in browser and the keyboard shortcut option unchecked, even after reboot.

If you don't want VK to open, I would suggest to not ctrl + shift + alt + P

Of course you could report is to tech support too. http://support.kaspersky.com/helpdesk.html


Thx "rudger79" for testing with me...
I appreciate you a lot, but I don`t like compromise.
It must be work because I used this key combination in other program.

Dear Kaspersky`s support PLEASE FIX THIS ISSUE

best regards
rudger79
You must contact support from the link I supplied. They might have a work around and/or maybe address it in the next patch.
Rodion Nagornov
Bug #292725
zeljko.n
I dont want to open new topic so i will just continue here.
Latest version of KIS 2014,same problem.
All options disabled in KIS 2014 (secure data input and virtual keyboard) but after ctrl+alt+shift+P still opens Kaspersky virtual keyboard.
As i see that i a bug and is there any news when will that be fixed?

Thank you
Rodion Nagornov
Do you have the patch F installed?
zeljko.n
Yes,same problem.
2SeaBee
KIS 15.0.1.415 ©
Same problem, even if "Open Virtual Keyboard by typing Ctrl+Alt+Shift+P" is disabled KIS blocks this shortcut in all other programs.
Very annoying.
iamntz
Wow, almost two years later, this wasn't fixed yet. And the recommended solution is this:

QUOTE
If you don't want VK to open, I would suggest to not ctrl + shift + alt + P


bravo.gif

How should I deal with apps that use that shortcut for useful things? Should I change that shortcut in every single app I use?

(btw, on KAV, i found no setting to disable this keyboard and disabling AV doesn't disable the VK as well...)
Egor Kurnev
Hello,

This problem is marked as fixed on latest 2015 version and it doesn't reproduce on my machine with KIS 2016 installed. What exact version do you have installed?
iamntz
AV Version:



Hitting CTRL+ALT+SHIFT+P will open this:



I hope you're not trying to tell me that something that shows up just after I installed KAV and it has Kaspersky lab on it's top-left corner is not related in any way with KAV...
3x0gR13N
Latest version is 15.0.2.361 http://forum.kaspersky.com/index.php?showtopic=316121
iamntz
QUOTE(3x0gR13N @ 22.07.2015 20:09) *


Oh... It seems that updater doesn't really do its job?

Anyhow, I updated (and I lost all settings, because this is how it should be done!), and... same problem.
3x0gR13N
FWIW, I can't reproduce the issue on 2016 version, to be released in a couple of weeks... unchecking Virtual Keyboard hotkeys in settings works without problems.
iamntz
QUOTE
unchecking Virtual Keyboard hotkeys in settings works without problems.

I feel there was a misunderstanding somewhere: i'm using Kaspersky Antivirus, not Kaspersky Internet security.

That being said, I don't even have an option to disable VK. It's just there...
3x0gR13N
Sorry, completely forgot that KAV doesn't even have that option, let alone if it works correctly... it's been a while.
You can manually disable the hotkey by editing the registry, but at your own risk (as it's unsupported). Disable KAV self-defense and exit the application from sys tray. Run>regedit, open HKEY_LOCAL_MACHINE\SOFTWARE\KasperskyLab\AVP16.0.0\settings (or the 64bit equivalent), find UseVirtualKdb DWORD and change it to 0 (from 1). Start KAV and enable self-defense. Now you'll be able to use VK only via product interface.

I can't verify if it's the same registry value for v2015 (as I'm on 2016), but it's shouldn't be different.
iamntz
Thanks, that works... partially smile.gif

I mean the VK stops showing up, but the shortcut is still disabled

On KAV, the right path is this though:
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\KasperskyLab\AVP15.0.2\setting\UseVirtualKdb
3x0gR13N
I'm out of ideas, sorry. I can't verify that changes I make are working because hotkeys are behaving oddly on my system (I can set ctrl+alt+shift+p for an app even without any changes to KAV but can't rebind it to KAV or other hotkey later), whether it's because of Win10 or KAV. You could try contacting support and explicitly request a way to disable VK hotkeys on KAV.
iamntz
Contacted the support, they asked for a screenshot of the problem. After two days. No rush...
3x0gR13N
Please post you request number here so that a Kaspersky employee can expedite the solution.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2015 Invision Power Services, Inc.