Help - Search - Members
Full Version: problem with minecraft launcher connecting
Kaspersky Lab Forum > English User Forum > Protection for Home Users > Kaspersky Internet Security & Anti-Virus for Windows
mys3lf
kis 2013 seems to be blocking the minecraft launcher from connecting to minecraft.net servers. i have tried putting an exclusion and trusted application on the launcher but it still doesn't allow the connection. can anyone suggest a solution?
richbuff
Which build number of version 2013? GSI report?

Please see the fifth Important topic.
mys3lf
i am currently using KIS 2013 13.0.1.4190. attached is the getsysteminfo link. get system
richbuff
Please inform Tech Support of this issue: https://my.kaspersky.com/en/support/helpdesk
JohnathanAM
I'm trying to play minecraft after installing kaspersky. Problem is, the zero-day exploit protection is blocking it based on how it was launched. I launch my minecraft in a unique way i must admit:
I use a batch file that temporarily changes the %appdata% variable so i can run minecraft outside of the default location
(it removes the threat of people navigating to that folder and stealing login info as i've had done before, as well as enables me to move files around without worrying about breaking it.)
then runs magict.exe which is magic launcher (a custom minecraft launcher)
however, i need to know how to let kaspersky know that i trust this batch file and everything it does, seeing as i wrote it and understand what the 2 lines do. attached is the batch file's code.
CODE
set APPDATA=%CD%\data
bin\magic.exe


update: setting custom settings in kaspersky to ignore java's behavior completely fixes this problem, however, i know how much java can be used to exploit a system, so i would still like to know how to just trust this batch file and it's child processess.
double update: NEVERMIND, it just lets me log in now, but now i can't login to any multiplayer servers. giving me the error
QUOTE
java.net.ConnectException: connect: Address is invalid on local machine, or port is not valid on remote machine
JohnathanAM
update^3 there are 2 java.exe processes in the applications list. if i completely explude both of them, minecraft works fine. again: just a temporary solution i hope. I have added all the batch and exe files to trusted but only changing java's settings "fixed" it.
Rassilon
For what it's worth. I have the same issue under Windows 8. KIS 2012 worked properly with Windows 7, but the upgrades to Windows 8 and KIS 2013 have been a huge step backwards.
Rassilon
QUOTE(JohnathanAM @ 31.12.2012 05:05) *
update^3 there are 2 java.exe processes in the applications list. if i completely explude both of them, minecraft works fine. again: just a temporary solution i hope. I have added all the batch and exe files to trusted but only changing java's settings "fixed" it.


Just two? On the Applications Control tab I see 18 entries if I search for Java, including multiple entries for Java™ Platform SE binary, and two copies of jre1.7.0_13.msi (one under ORACLE AMERICA, one at the top level.) On the offchance they were leftover from old builds, I deleted the entire list, ran Minecraft again, and the same 18 entries were recreated.

On the Firewall tab I only see one, and it has full permissions, to no effect. There is no other process there with JAVA or JRE in its name.
richbuff
QUOTE(richbuff)
Please inform Tech Support of this issue: https://my.kaspersky.com/en/support/helpdesk


Please contact Tech Support, and they will provide you with the correct workaround.

edit: topics merged.
grichard
After some testing I discovered that magiclauncher uses random local ports in the range of 53300-53499 but only the remote ports of 443 and 80. So after creating rules for just the remote ports I was able to get magiclauncher to use network resources again!

Here is a guide that I typed up for anyone else that may be having this same problem with magiclauncher and Kaspersky Internet Security.
I also was to get my minecraft server on the same computer to work again by creating a TPC and UDP network rule for local port 25565. If anyone needs a guide for that please let me know.

Open Kaspersky Internet Security 2013.
Click on Applications Activity.
At on the top left there should be a drop down menu with "Running" selected.
Click on the drop down menu and select "All".
On the top right there should be a search bar.
In the search bar type in: javaw
Right click on "Java™ Platform SE binary".
A popup menu should appear, select "Application rules".
A new Window named "Application rules should open.
Click on the "Network rules" tab.
Right under the "Network rules" tab and to the left you should see "Add".
Click on the "Add" button.
This will open a "Network rule" window.
For "Action:" Make sure "Allow" is selected.
For "Name:" you can name it "Magic Launcher - 443".
Click the check box net work "Protocol:".
Make sure "TCP" is selected to the right of "Protocol:".
For "Direction:" select "Inbound/Outbound".
For "Remote ports:" type in 443
Leave the field for "Local ports:" blank.
For "Address:" select "Any address".
Click on the "OK" button at the bottom.

Right under the "Network rules" tab and to the left you should see "Add".
Click on the "Add" button.
This will open a "Network rule" window.
For "Action:" Make sure "Allow" is selected.
For "Name:" you can name it "Magic Launcher - 80".
Click the check box net work "Protocol:".
Make sure "TCP" is selected to the right of "Protocol:".
For "Direction:" select "Inbound/Outbound".
For "Remote ports:" type in 80
Leave the field for "Local ports:" blank.
For "Address:" select "Any address".
Click on the "OK" button at the bottom of the "Network rule" window.
Click on the "OK" button at the bottom of the "Application rules" window.
Click on the "Close" button at the bottom of the "Application Activity" window.


I hope this helps! biggrin.gif
Ten37Jim
This works for the Feed the Beast launcher aswell, many thanks!!
biggrin.gif
richbuff
Welcome. Please, try and see if the workaround is still needed after Patch G for 2013 is installed. Information about Patch G is linked here: http://forum.kaspersky.com/index.php?showtopic=262466
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.