Help - Search - Members
Full Version: How to Disable the Load Password Manager on Windows startup?
Kaspersky Lab Forum > English User Forum > Protection for Home Users > Kaspersky PURE & Kaspersky Total Security
Scolpy
Hello!

I've tried to fined way to disable Password Manager from being run at windows start but I couldn't find anything that can disable it.

I found this article:
http://www.kaspersky.com/support/pure/safe...m?qid=208281320

But I don't have the option "Load My Password Manager on Windows startup" as you can see in that picture:
http://www.kaspersky.com/support/images/su...7_4%28en%29.gif


So how can I disable this? unsure.gif

Thanks!
Danila Tyurin
IN PURE R2 can't disable autorun KPM.
tomo45
I have just upgraded my PURE to R2 but since the upgrade, on the startup of the PC (and obviously KPM) I keep getting the KPM admin password request screen, I have selected in KPM settings for "authorisation method" that authorisation is via "USB" and not the "admin password" - how can I stop this admin password request on startup of the PC/KPM?

Mark.
purushotam
hi, once started, how can i disable the password manager? I don't find any option to disable the load password manager on windows start-up.


My Config:

Windows 7 Ultimate x86

Kaspersky Pure 9.1.0.124
Sjoeii
You can do it in settings within password manager
JohnH2O
QUOTE(Sjoeii @ 4.03.2011 06:36) *
You can do it in settings within password manager

Please tell me how to access this setting.
unsure.gif
JohnH2O
QUOTE(rudger79 @ 4.03.2011 15:56) *

Sorry rudger79, we are talking about the password manager in Pure 9.1.0.124, not the standalone Password Manager from Kaspersky.
rudger79
Yes, according to the tech article, it should be the same process, although can't see that option in the PURE2 screenshot. http://support.kaspersky.com/pure2/pm?qid=208283077
JohnH2O
QUOTE(rudger79 @ 4.03.2011 16:22) *
Yes, according to the tech article, it should be the same process, although can't see that option in the PURE2 screenshot. http://support.kaspersky.com/pure2/pm?qid=208283077

OK, but where is the “Load Password Manager on Windows startup” option??? It is not visible in the screen-shot in the referred Article: 5065 either.

Lucian Bara
http://forum.kaspersky.com/index.php?s=&am...t&p=1558843
Short answer: It can't be disabled, wait for 2012 etc.
Petr Filippov
You can make a smart trick with marking the stpass.exe in Application activity but surely this issue will be fixed in next version.
Thanks
JohnH2O
QUOTE(Petr Filippov @ 9.03.2011 12:00) *
You can make a smart trick with marking the stpass.exe in Application activity but surely this issue will be fixed in next version.
Thanks

A brilliant temporary solution. Thank you very much.
Vorpius
QUOTE(Petr Filippov @ 9.03.2011 14:00) *
You can make a smart trick with marking the stpass.exe in Application activity but surely this issue will be fixed in next version.
Thanks


Hi,
please can you explain me how can i do this trick bacause i doesn't understand what are you talking about!
If i can stop password manager to startup with windows i will be very happy.
Thanks.
JohnH2O
QUOTE(Vorpius @ 19.03.2011 15:31) *
Hi,
please can you explain me how can i do this trick bacause i doesn't understand what are you talking about!
If i can stop password manager to startup with windows i will be very happy.
Thanks.

I understood Petr Filippov's advice like this: Mark stpass.exe as an 'Untrusted application'.
I did it this way: Computer Protection (Main window) > Security Zone > Applications Activity. Find the process 'stpass.exe', right click, select 'Move to group' and then select 'Untrusted'. b_lol1.gif

In most cases the PW-icon is not displayed in the system bar (at boot-time), instead you will have a green message box with “Launch of stpass.exe is denied ...”. Some times the icon appears, but you are not allowed to start the application. In this occasions you might find 2-300 entries in the log with this text “14.03.2011 11:52:24 stpass.exe Access to another process memory c:\program files (x86)\kaspersky lab\kaspersky pure\kaspersky password manager\module retargetable folder\stpass.exe Denied: Reading another processes memory “.
Petr Filippov
JohnH2O
I think marking into Untrusted is so cruel for stpass.exe happy.gif

I can advice make it a little bit tricky (at the image). I think we can do it even more complex, but in principle the Untrusted group can help the customer
JohnH2O
QUOTE(Petr Filippov @ 23.03.2011 08:45) *
I think marking into Untrusted is so cruel for stpass.exe happy.gif

Yes, I have been cruel, but fortunately the PURE system has forgiven me; I have not noticed any bad feelings.

Now I have done it the proper way (Rules for Application); I have given “the naughty child” ALL permissions except on: “Do not start!”. All of us, both stpass.exe, PURE and I, are happy! bs.gif
Vorpius
QUOTE(Petr Filippov @ 23.03.2011 10:45) *
JohnH2O
I think marking into Untrusted is so cruel for stpass.exe happy.gif

I can advice make it a little bit tricky (at the image). I think we can do it even more complex, but in principle the Untrusted group can help the customer


Thanks a lot b_grins.png It does the trick!!!!!!!!!
brain8891
QUOTE(Danilka @ 23.12.2010 11:40) *
IN PURE R2 can't disable autorun KPM.

then how to stop it completely i mean i dont want to secure any password and i changed my mind how to stop it
JohnH2O
QUOTE(brain8891 @ 23.04.2011 12:39) *
then how to stop it completely i mean i dont want to secure any password and i changed my mind how to stop it


Yes, you CAN stop the password manager completely. Read what Petr Fillipov tells in another thread; start with post #9

Good luck; it works!
Morwenna
Thanks for this tip on how to stop password manager. I was going nuts trying to find an option to turn it off.

One thing I'm unsure about: in Firefox 4 I had to disable "password manager autofill engine" in add-ons.

Is there anything to disable in Explorer 8 and how?
miceatemycat
i can't clear the password manager, even i turn off everything, i use exit everyday. help
if you guys could just ctrl + scroll to see more clearer
JohnH2O
QUOTE(miceatemycat @ 2.12.2011 04:13) *
i can't clear the password manager, even i turn off everything, i use exit everyday. help
if you guys could just ctrl + scroll to see more clearer

To prevent the Password Manager to start, try this:

PURE Main Window > Computer Protection > Security Zone (left side) > Application Activity (at the right) > Enter 'stpass.exe' in the search box > Mark the item when found > Right click > Select Rules for application > Click the Rules tab > Scroll down to the bottom, to the line 'Start' > Right click in the right column 'Permission'> Select 'Deny'. Close PURE and reboot.

Your image “Settings > Password > General settings” has nothing to do with the Password Manager. Please read the image text.

BTW, at the first I did not like the KPM, so I wanted to stop it. Now, when the KPM works properly, I have learned the benefits of this secured password manager.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.