Help - Search - Members
Full Version: KIS2010 - Vulnerability scan: reactivating AutoPlay feature in Vista
Kaspersky Lab Forum > English User Forum > Protection for Home Users > Kaspersky Internet Security & Anti-Virus for Windows
Meladeo
Hi,

I'm running KIS2010 and recently ran a Vulnerability scan for my laptop. Among a few other things, KIS2010 identified the following "System Vulnerabilities" related to the AutoPlay feature in Vista Home Premium:

'Autorun from network drives is allowed'
'Autorun from hard drives is allowed'
'Removeable Media autorun is allowed'
'CD/DVD autorun is allowed'

I acted on disabling these, which i've now seriously regretted....

I've tried the 'Rollback' option on the Vulnerability scan but this hasn't worked. I've rebooted my laptop a few times, but unfortunately AutoPlay is no more. For someone who uses Removable Media devices regularly, it's a major inconvenience not having AutoPlay.

Help!! I expected to be able to rollback if I had any problems, so why doesn't the 'Rollback' feature work like it should do? Does anyone know how I can get AutoPlay back?

Any help would be greatly appreciated.

Many thanks,

Meladeo
richbuff
Welcome. Please see: http://support.kaspersky.com/faq/?qid=208279917
Meladeo
Thanks. I notice this is for KIS2009. Can this be used for KIS2010 too? If this still a recognised error in KIS?
Thanks again.


QUOTE(richbuff @ 31.10.2009 01:21) *

richbuff
You're welcome. Same procedure applies for 2009 and 2010.

By the way, disabling autorun is a classic way of eliminating a lot of infection risk.
Meladeo
Thanks. Yes I agree in most instances, but when the removable media is Trusted, the Autorun feature allows you to make that choice. My KIS is automatically set to scan all media anyway so should pick any nasties up, one would hope....
Thanks again, i'll give it go.



QUOTE(richbuff @ 31.10.2009 01:47) *
You're welcome. Same procedure applies for 2009 and 2010.

By the way, disabling autorun is a classic way of eliminating a lot of infection risk.

Meladeo
Hi there. Right, I gave it a go and unfortunately it doesn't seem to work very well so not quite the fix I expected. I tried a few senarios...

1) It seems to work ok for a USB stick (which incidently has an 'autorun' file on it), so the AutoPlay feature somes up and asks if you want to launch. Great.
2) AutoPlay feature does not launch when I plug in a digi camera (it used to come up with a large choice of applications to use), now, nothing...
3) AutoPlay feature does not launch when I slot an SD card in to the laptop (again, AutoPlay used to come up with a large choice of applications to use), now, nothing...

Conclusion, if media has an autorun file on it, then AutoPlay will pick it up and launch (but will only show the autorun file in question to give you the option of launching it). Therefore if media does not have a autorun file, such as SD card containing photos, digi camera, etc, then AutoPlay does not work.

AutoPlay should be able to recognise any form of media plugged in.

Unfortunately it seems were back to square one.

Any suggestions?

Thanks





QUOTE(Meladeo @ 31.10.2009 02:17) *
Thanks. Yes I agree in most instances, but when the removable media is Trusted, the Autorun feature allows you to make that choice. My KIS is automatically set to scan all media anyway so should pick any nasties up, one would hope....
Thanks again, i'll give it go.

antikythera
have you tried tweakui?
Meladeo
Thanks for the tip. Yes, I gave it a go. No joy i'm afraid, 'Tweakui' can't fixed the problem.....

Has anyone else come across this problem?




QUOTE(antikythera @ 31.10.2009 12:06) *
have you tried tweakui?

mak74
Yes Meladeo i'm facing the same problem with autorun and autoplay.
antikythera
have you tried the steps in this MS support topic:

http://windows.microsoft.com/en-US/windows...toPlay-settings
Meladeo
QUOTE(antikythera @ 10.11.2009 01:31) *
have you tried the steps in this MS support topic:

http://windows.microsoft.com/en-US/windows...toPlay-settings


Hi Antikythera, yes tried this and no difference. You would expect this to work, but certainly when i slot in a SD card or plug in a camera for example, it's not recognised by AutoPlay. Very frustrating.....

Meladeo
QUOTE(mak74 @ 9.11.2009 20:04) *
Yes Meladeo i'm facing the same problem with autorun and autoplay.


I'm hoping we'll get there.... one day....
skykap
QUOTE(Meladeo @ 12.11.2009 12:21) *
I'm hoping we'll get there.... one day....


Greetings,

I'm having the same problem with KIS2010...tried many of the suggested fixes as well - no success.

The following did not work for me either: http://support.kaspersky.com/faq/?qid=208279917

Is there something else I need to do to correct this problem?

Any help would be much appreciated.
richbuff
Welcome. What OS? Please mention what steps you have tried.
skykap
QUOTE(richbuff @ 21.06.2010 21:04) *
Welcome. What OS? Please mention what steps you have tried.


OS=Windows Vista.
I suppose I should clarify that the "many" fix attempts were really just a few.
I confirmed that the AutoPlay settings in Vista via the Control Panel were set appropriately (to the best of my knowledge).

I also tried unchecking the autorun and autoplay boxes under the application settings via "My Security Zone" in Kaspersky IS 2010 (per another suggestion that I had read). Finally, I followed the steps outlined in your link http://support.kaspersky.com/faq/?qid=208279917.

I'm fairly unskilled with these types of computer related issues (sure you've heard that a time or two). I'm really good at following instructions, though...hope you can help, richbuff.

Thank you for your time.
RaytheBear
Hi to all,
It is quite funny that MS offers a fix for Autorun when they themselves (and Wiesely so) sent patches to disable the Auto Run because of the Obvious dangers this represents. Below are a few links which might help, some point out on "How to Disable ....." But I imagine if you do the Reverse proceedures it should work.
Other links + do a Google search i.e. "Autoplay Microsoft patch for Vista" should help you find which patch(es) did the disabling of....

Mind you I agree with other Wise people on this forum and leave the Autorun disabled. But that is your choice and good luck.

Ray
skykap
QUOTE(RaytheBear @ 21.06.2010 21:58) *
Hi to all,
It is quite funny that MS offers a fix for Autorun when they themselves (and Wiesely so) sent patches to disable the Auto Run because of the Obvious dangers this represents. Below are a few links which might help, some point out on "How to Disable ....." But I imagine if you do the Reverse proceedures it should work.
Other links + do a Google search i.e. "Autoplay Microsoft patch for Vista" should help you find which patch(es) did the disabling of....

Mind you I agree with other Wise people on this forum and leave the Autorun disabled. But that is your choice and good luck.

Ray


Please enlighten me to the dangers of enabling Autorun, RaytheBear. I want to be "Wise", too! I do not doubt that there are risks enabling this feature...but I do miss the utility of AutoPlay!

Perhaps I need to learn more about specific examples of the potential dangers...maybe then my so called problem will be more easily resolved...i.e. "don't enable Autoplay", end of story beer.gif

Thanks for any info...could use all the help I can get!
RaytheBear
QUOTE
Please enlighten me to the dangers of enabling Autorun,


Enlighten Thyself via research on Google or Bing or whatever your favourite search engine is.
I did not condemn those who want it, in fact; I believe I pointed out a few links + KWs to search on how to Re-enable Autorun.
Sooooooo again, good luck in your “Enabling Autorun research”

Cheers to you Skykap beer.gif
Ray

Edit: Now I can see why you and others may be a bit confused, I guess I forgot to add the links in my previous post, but nevertheless the Key words are there......
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.