Help - Search - Members
Full Version: RDP blocked in 2010
Kaspersky Lab Forum > English User Forum > Protection for Home Users > Kaspersky Internet Security & Anti-Virus for Windows
Pico300zx
Hi,
I have recntly upgraded to kaspersky 2010 edition. I am unable to remote desktop to my windows vista laptop Business edition where I previousl could.
If I pause or close kapesrsky I can Remote desktop to my Laptop immediately. If i restart kapesrsky while I am in my RDP session the RDP session freezes and I have to force close it and then can not re-establish a RDP connectionunless I close kapersky again.

I have done some reading and it sounds like I need to open my TCP port 3389 to inbound and outbound packets. How on earth I do this in 2010 is beyond me as all documents reference a anti hacking menu which I cant find?????
I have tried to create a resource rule in the firewall tab for port 3389 inbound and outbound but i dont think i did it right so i deleted what I did.

Please help, any instructions please put in step by step format.

Thanking you in advance.
Pico300zx
ok i think i figured it out. Just check what i did to make sure i havnt opened myself up to the world.
In the setting tab i went to Firewall then i went to
"settings" with-in the firewall menu.
Here i expanded the packet rules icon plus symbol and found the remote desktop icon which had a deny icon on it. (note changing this on its own didnt fix the issue) SO I have now changed the remote desktop icon under packet rules to Allow.
Next i go to resources and at the ottom of the list is the remote desktop application it has a inbound stream on port 3384 as but no outbound setting.
I click the add icon at the bottom make a exact copy but with a different rule name of the remote desktop rule and just change the inbound strem to "outbound stream". Once i did this and saved my changes walllaaa it worked.


SO did i do a good thing or is this the wrong way to do it??
BestSax
QUOTE(Pico300zx @ 1.09.2009 07:23) *
Next i go to resources and at the ottom of the list is the remote desktop application it has a inbound stream on port 3384 as but no outbound setting.
I click the add icon at the bottom make a exact copy but with a different rule name of the remote desktop rule and just change the inbound strem to "outbound stream". Once i did this and saved my changes walllaaa it worked.
SO did i do a good thing or is this the wrong way to do it??


First, I want to ay thank you! You helped me with the same probolem.

As quoted above, I didn't ahve to do that part. Perhaps that is how you have your router set-up.

Just changing the Packet as you suggested worked perfectly.

Thank you bravo.gif
shaf
@Pico300zx

I too just recently upgraded from KIS 2009 to KIS 2010 and I am lost. The interface is different and I do not see the word"Firewall" anywhere accept a few places on the help documentation. I cannot get an RDP session at all. Perhaps that is also why my databases will not update. I have been talking to support about that issue and have not resolved it yet. I am guessing whatever is blocking my RDP session form working is the same thing that will not allow my KIS 2010 to update its databases.

-Shaf
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.